Unable to Add Sync Module - final step never finalizes

I have been emailing Blink support back and forth but to no avail. They keep sending me the same links other support people have already sent me, nor seem to be taking the time to understand the issue. I also suspect the Blink form isn’t passing all the information on to the support people, as they are asking me questions I answered in the form.

Some info on my issue:

  1. I get all the way to the final step where it says ‘Sending Wi-Fi info to Sync Module’. It never gets past that. I see it disconnects me from the sync module and I was instructed by Support to reconnect to my local wifi (which I have).

  2. I ensured my wifi password has no non-alpha numeric characters

  3. My blink products are from the kickstarter (not sure if that makes a difference). I got it to work on whatever phone I had back then, but have not gotten this to work at all on the past few phones.

  4. I am on an Android 6.0.1 (Samsung Galaxy J7)

Help :frowning: I have read all the FAQs, gone through all the links support has sent me, I don’t know what to do.

Not 100 percent sure. But think you need at least 7.0 android.

KitKat 4.4 is the oldest supported version for the Blink app, so that’s not his problem, what software version is your sync module on @sykospark? Do you have a hidden SSID?

Hello!
No to hidden SSID. Not sure how to find out software version on my sync module. Is there a way I can connect the sync module to my computer and manually update the firmware/software?

It has been at least 3 years since I was last able to get the sync module connected.
Sync module model number is BSM00200U, if that is any help.

Thank you!!

Hi @sykospark unfortunately I don’t think there is a way to see your sync module software version until it’s been added to the app

Then it’s just a matter of clicking the icon in the bottom left corner of the main screen

Latest version is 1.79 but you can’t even get that far. Unfortunately the sync module can only be updated when connected to the Blink cloud service.

I just checked my old sync module and it has the same hardware version and works fine

What I suspect may be happening is because you havent used the module in so long that the current software that Blink may be trying to push to the sync module is failing or there is some other corruption. Have you reset the sync module by pressing the reset button with a paper clip until it starts blinking ?

Hello!
I did not try the ol’ paper clip method.
I went and stuck in a paper clip - the light turned red. It stayed red (no blinking, and I held it in for over 30+ seconds).
After it stayed red for a few minutes, I unplugged the unit and then re plugged it. It then went back to persistent green/blinking blue.

Unfortunately - I’m back at the same issue - stuck on ‘Sending Wi-Fi info to Sync Module’. Any other ideas? Thank you!!

Have you tried logging in and out of your app? Reinstalling your app? It would help if I knew more about your network as well, router make/ model for starters. Have you attempted resetting your router at any point?

1 Like

I have removed and reinstalled this app many times. :slightly_frowning_face:
I’m a Spectrum user running a NetGear WNR1000v4. I don’t think I’ve reset my router for about 2 - 3 months.
Another thing I’ve noticed is that I never need to enter the password for my sync module. Is that something that should be happening?

I’d give the router reset a shot, you’d be surprised how many issues that can resolve.

Let’s take a step back and retrace your steps … When you last got the sync module working … Was the only difference your phone model or have you changed your network in any way since then?

I’ve gone through several phones since the last time I got it working. I have also gotten a new internet provider (I went from DSL to Cable Modem, I believe).
Update - I have performed the following and now am getting a new error message (progress? hehe):
-(as mentioned, I reset the sync module)
-I completely restarted both cable modem AND router
-Uninstalled and reinstalled blink app on phone
-I created a new account with blink that has NO plus sign in the email address (just in case)

Now when I go to add a new system:

  1. I confirm lights match on the sync module (and it accepts that on the first go - before it used to make me confirm it twice)
  2. It auto connects to the BLINK-### network (before I had to manually choose it)
  3. It asks me to choose the network I want to connect to (my home network) - I enter and click Join
  4. It says ‘Connecting to Blink servers, this may take a minute’ and reconnects to my home network

but then! it says
Sync module failed to connect. The most common cause of failure when adding a sync module is an incorrect or mistyped wi-fi password.The password you entered is displayed above.

It is the correct pwd, I have even tried re-entering it, resubmitting it, and have gone through the process 3 times in a row, to no avail.

Try resetting the sync module again (just a 10 second PIN press) and pick a totally plain text password for your WiFi network (no special characters) and see if it takes it. How far away is your sync module from your router by the way? Oh and is your router dual band ? If so try segregating the SSIDs…for example “Home 2.4 GHz” and “Home 5 ghz” Blink is only compatible with a 2.4 GHz connection and maybe it’s seeing the 5ghz network instead or pinging back and forth between the two

Yah, I reset my pwd last year when I tried the last time to get Blink to work, so it only has alpha numeric characters.
Sync module is about 6’ away from router.
The wireless connection it’s connecting to is 2.4 Ghz.

You’ve been very kind in trying to assist me. I feel like we’ve tried everything :frowning:

@sykospark, this may be your issue. Recalled seeing in another forum thread regarding cameras that blink had to go into their system and administratively delete an old account. If your sync module is tied to another account, although it was yours, it may be blocked from being connected to your newly created account.

If that’s not the culprit, then judging by what I’ve read above, your sync module probably needs replaced. Again in another forum thread, there was an issue with a sync module that blink determined was caused by firmware updates. If yours has been offline for the length of time that you’ve stated above, then quite possibly it’s unable to function with the outdated firmware and unable to update because of the connectivity dilemma.

Hope one of these resolves your issues.

I agree at this point I’d email support and request an RMA for your sync module

I want to thank everyone, especially @A_Person, for their help. Blink has provided me a link to the RMA form.
Thank you!!

2 Likes

Glad to help , hope you’re up and running soon!

Make sure your router is transmitting on wireless 2.4 band. It has to be this band or Blink sync won’t see the router.
Get the router ip address from the your router specs. Go to a computer hooked to your network. In the http line type in the ip address example. 192.168.2.2. hit enter. A window should open asking for user and password. Most are admin and admin. Once inside the router OS find the wireless bands and make sure 2.5 band is TX. If it’s not checked do so and logout. Restart router. If you mess up don’t worry…just reboot the router.

Didn’t the OP say it was a faulty sync module that got RMA’ed?

My blink sync module went offline try to reconnect fail delete try to reinstall still fail wont connect even when I use a network with no security password it still fail giving the message about password is wrong try to call two days now no one answering the phone I’m really getting frustrated with this situation

Hi I think I have the same issue @nick_at_blink,
Also a kickstart blink 1st gen