Sync module won’t connect

Update my solution. You need to check whether the router is enable band steering. If yes, you need to disable it because router sometimes automatically change the device from 2.4G to 5G. But the module can’t support 5G.

I reset the modem, router, and blink Module. I Uninstalled the app, restarted my phone None of them worked Spend days doing that Then decided hard reset module Im sure i done this before But this time i pressed with paper clipper longer till red light started blinking Didn’t know should be blinking And gone trough the process modem updated and all is working again Hope this help

Don’t feel bad I am on my second one and it’s the same thing. Password incorrect. Never have been able to contact by phone with support. Filed two request for service one response. I believe i’ll take it back to Best buy for a refund. The lack of phone support is unexceptable.

very interesting. Every single time i’ve called, i’ve gotten a person. though you’re not the first to say this.

I was having the exact same issues as others. Changed modems and thought it would a simple switch. All other products connected with zero issues. Blink sync was the only one. I knew password was correct. I knew 2.4 was working fine. Read comments and was refusing to hook up to my phones hot spot. But I did notice a comment that went over looked. Holding in reset on sync module while plugging it in and getting the flashing red light. I tried this and it accepted my password and works again.

We encountered intermittent cloud connectivity this evening. All cameras went off line and then back on line. This cycle continued for hours. When online I could see that signal strength was full bars from all my cameras to the module and full wifi strength from the module to the router. Live view would not work even when the app indicated everything was online. We couldn’t get ahold of customer service so we contacted Amazon and raised a big stink. They too couldn’t get in touch with Blink. After 60 minutes on the phone with amazon discussing a full refund they were finally able to reach Blink customer service. Imagine that…lol. I spoke with a total idiot in their customer service center. They blamed it on my router and internet provider even after i explained all the tests I did. I work in IT so theres that. Anyhow they rebooted all my cameras remotely and magically…the cameras worked. So my next obvious question was where is the camera reboot option in the app. Answer…“there isn’t one. You have to remove the batteries to do that”. My response…“So you can reboot my cameras from Pakistan but I have to climb a ladder to do it?” BULL$^it I said.

I think they had an issue with there servers this evening or they had a lingering firmware update that didn’t push down. Something, but the reboot corrected my issue. BUT…we as customers need to DEMAND the option to reboot our own cameras via the app.

Blink has a long way to go. Had I known then what I know now I would not have purchased these cameras. GET YOUR act together Blink. You scheduling options suck, cameras are sluggish to come on line for live view and your customer support is a joke.

Hi everyone, i had this problem and figured out a solution that i did not see posted anywhere so i will add it here. Basically the problem just appears to be the authentication protocol that the blink module uses. that’s why its so hit and miss that it works with some routers and not others. I’ve shown the example of what is needed, basically set your router to use WPA2 Personal with TKIP. AES doesn’t seem to work nor do other security modes.

Hello,
What worked for me with the sync module was put your phone in AIRPLANE MODE when you first add the sync module to your system. I am using iphone 7 with iOS 12.1 with the most updated blink app and did have to update firmware on the sync module. Make sure you update your firmware more than once even if it says it was successful. Took two tries for me to get the actual firmware update.

I was able to update firmware and tried at least 20 times to get my sync module to connect until I tried airplane mode and connected to my home WIFI and connected as it should.

Gotta say, tech support just sent me another sync module and I sent the original back. It had the same issue and the firmware wasn’t updated when I received it. When I updated the firmware I noticed that you had to manually connect to the sync module whereas before the update it would pop-up a message and connect to the sync module. So make sure you are on your WIFI. Once you enter the serial number of your sync module it will tell you to manually connect to the sync module via WIFI. After you connect to your sync module it will ask for your home WIFI password so that the sync module can connect to the internet. After that it should connect to the Blink servers. Won’t work for everyone but this is what worked for me.

Shame that we are resolving these issues ourselves rather than an firmware update that will actually help solve these issues. And also there have been days when Blink customer support are not even working. Thanks for extending our stress and frustration.

I had all of the above symptoms. Same Xfinity Xfi package. Here was my solution: unplug power cord from sync module, press and hold the reset button with a pin, simutaneously plugging in the power cable, release the reset button, open app and go through process of sync. In my case it put it in some kind of mode to check for new firmware. It downloaded new firmware and I was then able to sync.

This was after calling comcast and blink back and forth about 20 times - 10 hours worth of headaches.

1 Like

This problem seems to be related to the network. Blink only supports 2.4 Ghz not 5 Ghz. If you buy a new router it probably comes with Smart Select to allow your device to choose the network to connect to. When I got a new router it seems the SM would try to connect to the 5 Ghz but that doesn’t work.

My solution was to turn off smart select, create the two different SSIDs for the router.
Then make sure my phone was connected to the 2.4 Ghz. Then connect the sync module to the 2.4 Ghz. This worked just fine.

Once it is setup, you can connect your phone or other devices to whichever network you want. Of course 5 G seems faster.

this is what did the trick for me…
2 MONTHS LATER

wheredidiputthatremo

Apr 17

I had all of the above symptoms. Same Xfinity Xfi package. Here was my solution: unplug power cord from sync module, press and hold the reset button with a pin, simutaneously plugging in the power cable, release the reset button, open app and go through process of sync. In my case it put it in some kind of mode to check for new firmware. It downloaded new firmware and I was then able to sync.

This was after calling comcast and blink back and forth about 20 times - 10 hours worth of headaches.
/end and start my rant

Blink never mentioned this once, had me run all sorts of diagnostics and had me purchase a new router, all while being without a security system. Blink you suck!!! This should be a first step how come I had to come find this tip on my own?

I discovered that mine was reverse blinking. The green was blinking and the blue was solid. I used a paper clip and pushed the reset button on the module and it fixed it. So happy after hoof trying to figure this out.

Hope this helps other who face similar issue.

My issue started on my Blink XT2 existing sync module, when my router was switched off abruptly.

  • My preferred home wifi SSID was not showing on the list of nearby wifi. My router was setup to broadcast the SSID
  • Adding my wifi SSID via “other” says password might be incorrect
  • I tried turning off 5 GHz wifi on my Linksys router, as suggested by some post here, but still no success
  • Connecting to my mobile hotspot, as suggested by some post here, worked, but sadly not a long term solution.
  • But at least it established that my home wifi not showing in the list of nearby wifi, is the main problem
  • At my wit’s end, I deleted the sync module system, and attempted to create everything all over again, as a new setup. But still my home wifi SSID was not showing in the list.
  • Next, I attempted to add a guest wifi SSID, hoping that it will show up in the wifi list. The router restarted to apply the new settings, and suddenly now my preferred home wifi SSID showed up together with the new guest wifi SSID.
  • I connected to my preferred home wifi SSID, and setup succesfully

So what could be the cause? Nothing definite. I suspect, at some point, after the router restarted, though not for the first time, the sync module was now able to detect my preferred home wifi SSID again.

Sorry for the long post, hope the details here can provide some clues to your issue.