Not saving full clip length

I have just purchased a Blink XT unit.

I’ve set my Blink XT to have a clip length of 30 seconds but it stops recording after a few seconds. I’ve turned off the option to stop recording when it motion stops but the clips are still not being fully recorded. I have a very fast connection here at home - on average around 90MBps. How do I fix this?

Also, the notifications are taking a really long time to come through. Considering it is only recording a few seconds of video, the notifications are taking minutes to come through.

And finally, I notice that even though the retrigger time is set to 10, it never gets retriggered?

Guessing signal strength from router to synch module and/or synch module to camera isn’t strong enough.

What I did was bench test all my Blink hardware before I installed it. That way everything was very close to each other and I confirmed full 5 bars signal strength for both synch module as well as all 6 of my XT outdoor cameras.

After confirmin system worked and was stable, then I installed only 1 camera at a time. Then retest it. Then mount the next camera. Test then repeat.

Yes this is OCD over the top. However I’m a retired field service computer and packaging machines tech. We start up little bits and pieces vs. Startup the entire machine. It’s the KISS method.

Thanks for the suggestion. I only have the one camera. And both the Camera to WiFi and the Camera to Sync Module signals are showing full strength. I’ve even just tried putting them all next to each other just in case the signal indicator was wrong but still no luck.

1 Like

Hey @antjnr,

Since your signal strength looks good, I would recommend contacting support so they can walk you through some troubleshooting steps! You can either submit a support ticket or call us at (781) 332-5465.

Thanks. Will do.

I’m having the same problem. I tried a lot turning off the Motion Detection, Changing the clip length then turning again Motion Detection, Tried everything but still same issue. Is there any solution to this ?

My cameras are doing the same thing. I purchased the bundle with the 3 cameras and all three cameras were only recording a 1-5 second videos even though the motion persisted. I contacted customer service and we power cycled the module, and cameras. Deleted and re added all cameras and module. Reset my router, set the setting to record for the full 60s and not to stop when the motion stops and a 10s trigger time. I have Gb internet, I get 900 MB on my Xbox on WiFi not hard wire, basically I have really good WiFi, not the sorry stuff from xfinity. Anyways. We ran the route this app and made the conclusion it was not my internet but the cameras after an hour trying to solve the issue. Since I only had them for two days I exchanged them at BestBuy. And you won’t guess the results. The same issue with a brand new set. I returned them, they aren’t reliable. That’s two different sets with the same issue. I just can’t be going back and forth. The price and quality of the image were great and the price is amazing for what you get, even the two way audio was pretty good though the first set had a distorted barely audible voice box. I hate saying this but beside those factors, unfortunately I couldn’t get two different sets to work reliably even with all the steps I took with customer service. I decided to drive 40 min out to another BestBuy because I’m assumed that maybe this BB has a defective batch and this might solve my issue. Nope. Only one of these records. The other two can’t even detect motion and the one that does record, after fixing the setting doesn’t get pass 4 seconds it did 8 once at a 60s clip length and stop when motion stops disable.

Eight cameras all set to 60 sec clip length, retrigger 10 sec, and do not stop recording if motion stops.
I discovered that if the first camera is triggered during an event, the following cameras involved during that event are recording at a reduced rate (5 - 10 seconds). I have an open ticket with support.

Interesting discovery.

I have two XTs that share a field of view. I am not experiencing this issue (yet). Keep us posted!

July 13 2019 I contacted customer service and they recommended that I power cycle the module, and cameras. Next they requested the serial numbers on the cameras and Blink tried refreshing/rebooting and updating the firmware for the cameras on their end. Next they requested I delete and re added the cameras with issues.

I’ve also reset my router (this is done automatically every 24hrs). As of today July 29 2019, I’m still having the same issue.

New user here. Purchased the 2 camera system. One camera is functioning correctly the other is not. It only records 1-4 second clips. Both are set to record 20 second clips with end clip early turned off. I’ve tried resetting the router and have power cycled the module but no luck

I’m experiencing the same thing. I’ve had my cameras for a while now, and they just starting recording ONLY about one second. I have them set for 25 seconds. And, I have them powered, not on batteries. They used to work, but all of a sudden, stopped taking the full length of the clip or not activating at all. It can’t be a battery issue. I bought power cables for them, and they were on Amazon and recommended for the Blink X2 cameras.

  1. Clip length only about a second long, no more than that
  2. In other cases, cameras not triggering at all.
  3. All cameras powered by electric cable (authorized cables)
  4. Used to work; stoppped working all of a sudden
  5. Signal strength strong between sync module and cameras
  6. Tried re-setting the sync modules
  7. Unplugged sync modules; waited and re-pluged in
  8. Deleted and re-installed the app

Nothing works
12/20/19

Looks like this is a common problem now. I have three outdoor cameras. They all used to work and record the full 20 seconds I have set when there was motion that long. Now I’m lucky if I get 3 seconds, never more than 5 seconds. They all changed at once just recently. I tried changing the clip length, turning off the setting to stop recording if motion stops, etc. Nothing works here, either. They worked as recently as last week, I think, but now they are all failing to keep recording. This is not doing the job I got them to do.

Granted it’s odd that three cameras would be doing the same thing, but whenever I have had a camera suffer from short clips, I have replaced the batteries, and all was well.

Cheap test to find out if this is the case by just doing it on one. If you already did that, not sure what else to suggest, other than to contact support and ask them…

Thanks for your reply. It is odd that all three would change at once, so I was thinking a firmware update might have caused it. Two of the three are on power supply, one runs on battery. All are having the same problem. Pretty easy to change batteries in one to try it. Thanks.

Battery change didn’t help. Also, new comment - I have one indoor camera that’s now doing the same thing. It’s not possible that this is a camera problem. It has to be a Blink problem as all 4 cameras were working last week and now are all having the same problem. Three outdoor cameras and one indoor model. This system is useless like this.