Blink Sync Module Issue

Hello there! I recently purchased the Blink. I opened the box to set up and plugged in the sync module. I noticed that I never got the green light to blink, let alone show up at all. Sat there, blue light steady, no blinking green light, nothing, I tried resetting the sync module, but nothing happened. I did get a blink RED light one time. But thereafter, nothing, Can someone lend me a hand? I couldnt find a number to call customer service. Thanks in advance!

submit a support ticket or call (781) 332-5465,

Their customer support is useless as you will be speaking with someone who can barely speak clear English. I got so frustrated, I wanted to throw my phone. BTW, I am having the same issue with the module and the steady blue light.

@nick_at_blink
Can you help?

Same issue here. After an HR with support they are just sending a new module…anyone figures this out let me now. It was working great at 1025 eastern standard time then just stopped

I have the same problem Blue light only, will not sync, no security, no pictures nada. opened a ticket had several emails then nothing. deleted and reinstalled blink app. I do not get the screens they reference under manage acct. so no help so far, I guess I may have to return the blink, to bad I sure was hoping this would be the one.

Hi @kwhiteusmc and @Linda3610,

I am very sorry you are having these issues! I am going to tag @Bob_at_Blink so he cam chime in.

Thanks @Mark_Griffith!

Hey @edtapalla,

I reached out to you via our support email. Could you please get back to me at your earliest convenience.

Thanks

This seems to be a growing issue. My Blink has the same symptoms as @edtapella
Hey edtapella, have you come across a solution that you can share?

Add me to the list of folks who have this exact problem. Just sent a message to nick_at_blink. Bought brand new, 5 days old. Worked great at first, then needed to use the app to change my wifi SSID. Update failed, restarted the app, had to hit reset button on sync module to get solid green, blinking blue, app failed to up-date wifi SSID again, unplugged sync module, brought it to my desk and plugged it in so I could work on it there, never got green light again… Tried resetting it multiple times, using phone chargers, different outlets, etc… but never got a green light again. Very disappointed that the reset doesn’t actually seem to completely reset the sync module back to factory, so a full, fresh, re-configuration van be done.

Clock starts ticking on Blink support tomorrow (12/26) at 8am. If Blink doesn’t get this resolved by 12/28, back to the store it goes for a refund.

Update #1 - 12/26: Blink support contacted me via email, gave me these instructions to follow, and it worked like a charm. If you are having the same issue, follow these instructions:

Update #2 - 12/26. - IMPORTANT! Blink support informed me that for Step 4 “Sync Module Firmware Update” to appear in the menu, after you select “Manage Account”, it is a setting that has to be turned on by Blink Support, for that option to be available. The best thing to do would be to open a ticket, and refer to this community post if you are having the same issue I described in my post.

With this, there are a few steps that I would like you to follow so we can get your Sync Module in working order:

  1. Go ahead and open up your Blink application.

  2. Once you’re in the app, go ahead and tap the menu icon with the three white lines on the top left of the screen.

  3. In the menu that pops open, please select “Manage Account”

  4. From there, you should see an option that says “Sync Module Firmware Update”, please select that. If you do not see that option, please close out and reopen your app.

  5. In the box that appears, please type in the serial number of your Sync Module. Once finished, you can go ahead and tap “Get Firmware”

  6. After that loads (this may take up to a minute or so), please go into your device Settings --> WiFi. From here, please select your BLINK-5727 network and connect to it.

  7. Once that is connected, go back into your Blink application and tap “Update Sync Module”

These steps once performed correctly should eventually restore your device to a solid green blinking blue light pattern. Once it does, you can hop back into your WiFi Settings and connect back to your normal home network.

From there, if you go back into your Blink app, you should be able to add your Sync Module successfully.

I have not yet tried the update firmware. Just wanted to say I’m having this exact problem. 2 months ago I was able to connect to the sync module. Now that I’m ready to use it I cant get the green light on the sync module.

I’m having this issue. However it’s during my initial setup. Thus when I go to manage accounts there is no firmware update option. I’ve reset the app several times. What should I do? Thanks.

@nick_at_blink,@ marvin_at_blink. I am facing the same issue. Can you help?

Same issue of repeated sync module offline errors. The system worked flawlessly more or less for two years and then this has been happening frequently over the last month. As other posts have noted, it happens even if the sync module is close to the router, and other devices on the network have no problem this still happens.

The module keeps reporting weak Wi-Fi signal, but, using a separate device to measure Wi-Fi strength on the same network placed exactly the same location shows that the Wi-Fi signal is strong

Following have not made any difference to the issue: Changing Wi-Fi network;
Resetting or deleting the sync module;
Rebooting the router, and forgetting the network settings in my phone, as suggested
Creating a new network
Moving the module

Blink sent me a new module and that has the same problem

I have tested the Wi-Fi strength in various locations where the module shows it is weak. The separate programs and testing options show the Wi-Fi is strong when The module reports that the signal is weak, in exactly the same location

I’m wondering if this has to do with a 2.4 GHz and 5 GHz combined network and will perhaps see if I can set up a separate 2.4 GHz network just for the Blink

Has anyone tried that option?

I split mine out have noticed much better performance.

@nick_at_blink We recently moved and changed internet providers, and I am unable to set up my system in the new house. There is no option to update firmware; and when I try to set it up, it tells me it wants to join Blink_1218 - then just goes back to the same screen and repeats itself. If I try to do the manual sync, it says to check my wifi when I return to the Blink app. Please help!

Same problem!!!
Only a blue light and no blinking green. Tried the re-set. Then tried what suggested in this forum copied below. I don’t have the option of “sync module…”

Very frustrating !

In the menu that pops open, please select “Manage Account”

From there, you should see an option that says “Sync Module Firmware Update”, please select that. If you do not see that option, please close out and reopen your app.

The support team has to send that ability to your account.

your best bet is to contact customer service.

Well. I was happy customer two week until i had today blinking green light :hushed:
Sync modul is off, green/blinking, blue/steady
Also resetting and deleting sync modul, but blinking green repeat every one minute and then still for 15sec.

Clement_Singarajah I quoted your post because you have a clue for what I done.
I have on ruter 2.4GHz and 5GHz combined network on house. When I turn off 5GHz network…green light became steady and issue is gone :relaxed:

Now I am sure that all mine issue related with 5GHz network.

I’m curious…do you share the same SSID with 2.4 and 5? I have a router that supports both. Separate SSIDs. Never had an issue.

1 Like